Random header image at GumiElectronic

Kawai R-100 Factory Reset

Kawai R-100 Factory Reset

January 16th, 2011  |  Published in Kawai R-100  |  4 Comments

If your R-100 is suddenly confused and misbehaving, the factory reset procedures might knock the sense back into it.

I found this info in this circuitbenders thread. It was originally written in French. Here is my translation with help from Google Translator:

“To initialize the parameters only: hold down the [ERASE] button while you turn on the power. To clear the pattern/song data: penny voltage device, hold down the No. 1 button and press [ERASE], then [ENTER] twice.” (I have no idea what “penny voltage device” means, but it’s the same procedure as listed on p.21 of the Owner’s Manual)

Note that these procedures will reset all of your custom settings and erase all of your patterns.

I performed both of these procedures on my R-100 and now it’s 100% functional again. The machine became rather confused after I tried installing a global pitch mod and mucked around with the 16MHz xtal. The sequencer was locking up and the display was showing crazy characters and pattern parameters. This solved the problem.

Responses

  1. drummchimp says:

    April 14th, 2012at 9:01 am(#)

    wowza! i’ve had one of these for a few years after finding it in the bin outside a studio…it just made spazzy noises & the display was all garbled…now it works fine! and it was free!! woohoo!!!

  2. Björn Nilsson says:

    April 16th, 2013at 2:14 am(#)

    I also recently got my hands on this beast…but it acted strangely…just as described..and sounds just vanished…but this trick helped me. But if i leave for a while (a week..or longer) the problem re-appears…donno if it hhas something to do with the internal battery…haven’t been changed for more than 5 years..probably much longer. Thanx anyway :-D

  3. 477 says:

    June 25th, 2013at 12:18 am(#)

    Mine does this periodically too, even during use sometimes, and I’ve changed my battery… If I stumble upon a solution, it’ll be posted here.

  4. John says:

    December 11th, 2013at 10:48 am(#)

    I have Kawai R100 vintage drum-machine and it has issue with distorted output signal, my techman found a problem in broken IC M6009-0103FP (U26 on schematic), does anyone help me where I can find this IC or please tell me a place for ordering? Also I’m looking for R100 or R50 like “for parts” to get this chip from there.
    My email is: provereno@pisem.net

Leave a Response

 

Photos

_____________________________________________